Feb 11, 2014

Framework that is incompatible with the target instance of SQL Server: "Deploy error SQL01268: CREATE ASSEMBLY for assembly failed because assembly failed verification". To resolve this issue, open the properties for the project, and change the .NET Framework version.


When we will deploy a CLR object like CLR stored procedures or CLR data types we may get error message like:

Framework that is incompatible with the target instance of SQL Server: "Deploy error SQL01268: CREATE ASSEMBLY for assembly failed because assembly failed verification". To resolve this issue, open the properties for the project, and change the .NET Framework version.

Cause: It is due to mismatch of .net framework. Either you're creating CLR objects in visual studio 2010 in .net framework version 4.0 etc.

Solution:

Change .net framework version to 3.5 or according to sql server version. For this right click on your project and choose Properties. Now select Compile tab and click on Advanced Compile options... and change the .net framework


And build the project solution.

No comments:

Post a Comment